SSL certificate expired (Let's Encrypt Root Certificate)
Incident Report for Callr
Resolved
All of our SSL certificates are generated with the correct chain (they always were). Customers need to make sure they update their root certificate store. Please contact support@callr.com if you are still encountering issues.
Posted Oct 03, 2021 - 08:00 CEST
Monitoring
On 30th September 2021, the root certificate that Let's Encrypt was using, the IdentTrust DST Root CA X3 certificate, has expired. Their new ISRG Root X1 certificate does not expire until 30th September 2024.

In some cases, the OpenSSL 1.0.2 version will regard the certificates issued by the Let’s Encrypt CA as having an expired trust chain. If you are using OpenSSL 1.0.2, your connection to our API and Website may be rejected with "SSL certificate expired". There are workarounds listed here: https://www.openssl.org/blog/blog/2021/09/13/LetsEncryptRootCertExpire/.

We are exploring options on our end.
Posted Oct 01, 2021 - 08:58 CEST
This incident affected: API, Customer Portal, and Real-time.